Archive for December, 2013

chromium & aarch64 ( I wish )

Posted: December 31, 2013 in Uncategorized

I’d rather like to be posting about my various efforts to port Chromium to aarch64. Unfortunately this isn’t that blog post.

I do have a good portion of the chromium test suite built and I do have the actual Chromium binary built too for aarch64. The problem is the environment to test it in. 

When I started working on this I was using the rtsm model and basically a good old fashioned aarch64 kernel with framebuffer. I’d built a more or less slimmed down fvwm and that worked well for running a linux based Chromium for aarch64. Cool.

Times changes and progress continues least it should be progress. Unfortunately the rtsm I was using was considered “old” so I moved up to the newer FVP Fastmodel. I’ve pulled in the latest lsk VE kernel hwpack_linaro-lsk-vexpress64-rtsm_20131204-545_arm64_supported.tar.gz and should be good to go right?

No. Immediate crash trying to start the kernel.

Errrmmm ok. So switching to hwpack_linaro-vexpress64-rtsm_20131125-536_arm64_supported.tar.gz, the resulting image boots. But I had switched over to using the ALIP OE image. As it starts to boot, it crashes with psplash. Awesome. So mounting the file system and disabling that I at least get to a command line prompt. 

So next I’ve built xf86-video-armsoc for aarch64 and pl111 (one small patch needed). Now to try and get X up and running again. It’s really no fun to regress and it’s especially no fun when you have some shiny new binaries you really want to run but can’t but such is the nature of the cutting edge sometimes. Wish me luck.